POWERWARE® EXTENSIONS

for
IBM® Director 3.1

User’s Guide
# Table of Contents

1 Introduction .......................................................................................................................... 1
   - Features and Benefits ........................................................................................................ 1
   - UPS Monitoring and Management Options ....................................................................... 2
   - Reference Documentation ................................................................................................. 3

2 System Requirements ............................................................................................................ 4
   - Requirements for the Director Server Computer ............................................................. 4
   - Requirements for the Director Management Console Computer .................................... 4
   - Requirements for LanSafe Systems .................................................................................... 4
   - Requirements for ConnectUPS X-Slot Card Systems ....................................................... 4

3 Supported Operating Systems ............................................................................................. 5
   - Director Server .................................................................................................................. 5
   - Director Management Console ........................................................................................ 5

4 Installation .............................................................................................................................. 6
   - For Director Servers and Consoles Running LanSafe ....................................................... 6
   - For Director Servers and Consoles Not Running LanSafe ................................................ 6
   - Configuring LanSafe to Forward Traps to the Director Server ......................................... 7

5 Initial Configuration .............................................................................................................. 8
   - Compiling MIB Files .......................................................................................................... 9
   - Discovering SNMP Devices .............................................................................................. 10
   - Performing Inventory Collection on SNMP Devices ....................................................... 10
   - Creating a Powerware UPS Device Filter ........................................................................ 11
   - Creating a Status Update Event Action Plan .................................................................. 12
     - Creating a UPS Simple Event Filter .............................................................................. 12
     - Creating an Event Action Plan ....................................................................................... 14
     - Associating the Events Filter with the UPS Events Plan ............................................... 15
     - Associating an Action with the Event Action Plan ....................................................... 15
     - Associating the Event Action Plan with Devices ......................................................... 16

6 Operations ............................................................................................................................. 19
   - Monitoring Tasks .............................................................................................................. 19
   - Management Tasks .......................................................................................................... 19
   - Starting the UPS Software ............................................................................................... 19
   - Monitoring Tasks .............................................................................................................. 19
     - Checking UPS Battery Conditions ............................................................................... 20
     - Viewing the Load Percent for a UPS .............................................................................. 23
     - Locating Model and Version Information ..................................................................... 24
## Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting Attribute Values</td>
<td>26</td>
</tr>
<tr>
<td>Using Resource Monitors for Quick System Monitoring</td>
<td>26</td>
</tr>
<tr>
<td>Viewing UPS Inventory Data for Quick System Information</td>
<td>28</td>
</tr>
<tr>
<td>Viewing UPS Event Logs</td>
<td>30</td>
</tr>
<tr>
<td><strong>Management Tasks</strong></td>
<td>31</td>
</tr>
<tr>
<td>Testing Your UPS Battery</td>
<td>31</td>
</tr>
<tr>
<td>Shutting Down and Restarting a UPS device</td>
<td>32</td>
</tr>
<tr>
<td>Setting Read-Write Rights in Windows</td>
<td>33</td>
</tr>
<tr>
<td>Shutting Down and Restarting Load Segments</td>
<td>34</td>
</tr>
<tr>
<td>Configuring Event Notifications</td>
<td>35</td>
</tr>
<tr>
<td>Limiting Event Notifications</td>
<td>35</td>
</tr>
<tr>
<td>Responding to Event Notification at the Director Management Console</td>
<td>36</td>
</tr>
<tr>
<td>Starting the UPS Software</td>
<td>36</td>
</tr>
</tbody>
</table>

7 **Powerware Technical Support**                                         39
CHAPTER 1

INTRODUCTION

The Powerware® Extensions tool for IBM® Director provides seamless integration of Powerware uninterruptible power systems (UPSs) into the Director Management Console. As a part of Powerware’s comprehensive family of power management applications, Powerware Extensions simplifies network management tasks for critical elements of server power protection. System administrators can easily monitor, diagnose, configure, set alarms, schedule self-tests, check battery conditions, gather inventory information, and control Powerware UPSs network wide from the Director Management Console.

With Powerware Extensions, users can simply double-click the UPSs integrated into the Director interface, and launch Powerware’s LanSafe or ConnectUPS™ X-Slot™ Card applications. All the powerful features and functions of these Powerware award-winning applications are now just a click away through the Director Management Console.

Features and Benefits

<table>
<thead>
<tr>
<th>Feature</th>
<th>Benefit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Seamless integration of UPSs into the IBM</td>
<td>Allows administrators to monitor UPSs on the network, in real-time, and obtain advance notice on critical elements of server power management, such as UPS battery status, load level, temperature, and alarms for battery replacement.</td>
</tr>
<tr>
<td>Director Management Console</td>
<td>Launch LanSafe and ConnectUPS X-Slot Card applications directly from within IBM Director.</td>
</tr>
<tr>
<td>UPS inventory management</td>
<td>Ability to maximize systems availability through the IBM Director user interface.</td>
</tr>
<tr>
<td>UPS load segment control</td>
<td>Control UPS load segments (separate receptacle groups).</td>
</tr>
<tr>
<td>UPS reboot and scheduled shutdown</td>
<td>Increase run time by up to 50% on mission-critical loads. Switch different UPS loads on and off at predefined times or power failure situations.</td>
</tr>
<tr>
<td>Network-wide UPS battery test</td>
<td>UPSs can be commanded to reboot specific computer systems or internetworking devices either locally or remotely over the network.</td>
</tr>
<tr>
<td>Standard RFC1628.MIB and PowerMIB XUPS.MIB</td>
<td>Initiate scheduled shutdown/reboot tasks with integrated UPS applications.</td>
</tr>
<tr>
<td>SNMP set and get operations support</td>
<td>Test battery health for all UPSs throughout the network.</td>
</tr>
<tr>
<td>Support</td>
<td>Compatible with the Internet standard (RFC-1628) UPS MIB. In addition, a Powerware proprietary XUPS.MIB is provided for extra functionality such as load segment control.</td>
</tr>
</tbody>
</table>
### UPS Monitoring and Management Options

From your Director Management Console(s) with Powerware Extensions installed, it is possible to view many system configurations. A few examples are listed below:

1. A Powerware UPS communicating serially with a PC running LanSafe (see Figure 1).

![Figure 1. Powerware UPSs Communicating Serially with Computers Running LanSafe](image)

When the Powerware Extensions tool is employed, LanSafe must be installed on the Director Management Console machine before systems can be monitored and controlled using LanSafe. It is advisable to install LanSafe on the Director Server machine.

2. A Powerware UPS with a ConnectUPS-X Web/SNMP Card communicating over a network with a PC running a Web browser (see Figure 2).

![Figure 2. Powerware UPS with ConnectUPS-X Web/SNMP Card](image)

For viewing Powerware UPSs with the ConnectUPS-X Web/SNMP Card, LanSafe Remote Services and a Web browser must be installed on the Director Management Console.
3. A ConnectUPS-X Web/SNMP Card or ConnectUPS-MX SNMP Card in a Powerware UPS supporting peripheral equipment such as a hub, but with no associated PC (see Figure 3).

![Figure 3. Powerware UPS Supporting a Hub](image)

4. Agent machines with LanSafe or viewing the ConnectUPS X-Slot Card user interface with a Web browser (see Figure 4).

![Figure 4. Director Agent Machines](image)

To discuss other possible configurations, please contact Powerware Technical Support (see page 39).

**Reference Documentation**

For more information about Director, refer to the *IBM Director Version 3.1 User's Guide*, in particular the following chapters:

- Chapter 1. Introduction
- Chapter 5. Using the Director Management Console
- Chapter 6. Inventory Management
- Chapter 9. Event Management
- Chapter 14. SNMP Management

For more information about LanSafe, click F1 from any window for online help.

For more information about the ConnectUPS X-Slot Card user interface, open the Help menus.
CHAPTER 2
SYSTEM REQUIREMENTS

IBM Director 3.1 or above must be installed in accordance with IBM requirements and procedures. Refer to your IBM Director documentation.

Requirements for the Director Server Computer

The Director Server computer requires the following:

- Microsoft SNMP Service installed and running.
- Microsoft SNMP Trap Service stopped.
- Microsoft SNMP Trap Service set to Disabled or Manual.
- Configure the computer to discover SNMP devices.
- To monitor LanSafe systems, LanSafe must be installed.

Requirements for the Director Management Console Computer

- Microsoft SNMP Service installed and running.
- To monitor LanSafe systems, LanSafe must be installed.

Requirements for LanSafe Systems

- Either or both of the following:
  - LanSafe III, v4.17.3a or higher
  - LanSafe v5
- Configure Microsoft Windows® to forward SNMP traps to the Director Server. See page 7 for more information.

Requirements for ConnectUPS X-Slot Card Systems

- 10 Mb ConnectUPS X-Slot Card, firmware v1.39 and above
- 10 Mb/100 Mb ConnectUPS X-Slot Card, firmware v2.03 and above
- A Web browser must be installed on the computer that monitors and controls the UPS.
- For shutting down the computer, install NetWatch Clients 4.01 software available from www.powerware.com.

Configure the ConnectUPS-X Web/SNMP Card for read/write access and trap forwarding as follows:

1. Set “Write Access Managers” to include the Director Server.
2. Set “Trap Receivers” to include the Director Server.

To determine your Web card firmware version, either browse the MIB for upsIdentUPSSoftwareVersion, or click Configuration and Web/SNMP Card Configuration on the ConnectUPS X-Slot Card.

CHAPTER 3

SUPPORTED OPERATING SYSTEMS

Systems supported by the Director Server and Director Management Console are listed below.

Director Server

- Microsoft Windows NT® 4.0 Server
- Microsoft Windows NT 4.0 Enterprise
- Microsoft Windows® 2000 Server
- Microsoft Windows 2000 Advanced Server

Director Management Console

- Microsoft Windows NT 4.0 Server
- Microsoft Windows NT 4.0 Enterprise
- Microsoft Windows NT 4.0 Workstation
- Microsoft Windows® 98
- Microsoft Windows 98 SE
- Microsoft Windows® XP Professional
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Professional
- Microsoft Windows 2000 Advanced Server
CHAPTER 4
INSTALLATION


When you install Powerware Extensions on a machine running Director Server or the Director Management Console, you have the following capabilities:

- **Running LanSafe from the Director Management Console** – You can open LanSafe at the Director Management Console to monitor and manage any UPS in your network that is running LanSafe if: 1) you install LanSafe on the Director Server and Director Management Console, and 2) configure Powerware Extensions as described in Chapter 5 on page 8.

- **Running the ConnectUPS SNMP/Web Card from the Director Management Console** – You can open a ConnectUPS SNMP/Web Card at the Director Management Console to monitor and manage any UPS that is attached a ConnectUPS SNMP/Web Card on the network if: 1) your Director Management Console has a Web browser, and 2) you configure Powerware Extensions as described in Chapter 5 on page 8.

- **Using the Director Management Console SNMP Browser to access SNMP-supported information about a UPS** – After installing Powerware Extensions, see Chapter 6 on page 19.

For detailed examples of configurations, see page 2.

### For Director Servers and Consoles Running LanSafe

**IMPORTANT** Powerware Extensions for IBM Director should be installed on the IBM Director Server machine and then on the Director Management Console machines.

2. Download the Powerware Extensions setup program from Products→Software→Downloads.
3. Extract the files to your hard drive.
4. Run Setup.exe.
   
   The setup program is self-guiding.

### For Director Servers and Consoles Not Running LanSafe

Install LanSafe before installing Powerware Extensions.

2. Download the LanSafe setup program from Products→Software→Downloads.
3. Extract the files to your hard drive.
4. Run Setup.exe.
5. If prompted, select Yes to temporarily terminate SNMP services.
6. At the Welcome screen, select Install.
7. You are prompted to choose the type of installation:
   - If installing LanSafe III, select **Install remote services only**.
   - If installing LanSafe v5, select **LanSafe only**.

8. Select **Continue**.

9. Enter **Destination Directory** and select **Continue**.

10. Click **OK**.

   After installing LanSafe, install Powerware Extensions as described in the previous section.

### Configuring LanSafe to Forward Traps to the Director Server

In LanSafe, the Microsoft SNMP Service must be installed and your Microsoft Windows operating system must be configured to forward traps to the Director Server. On systems other than Windows NT, this configuration is done on the SNMP Properties – Traps tab (see Figure 5).

![SNMP Properties – Traps Tab](image)

**Figure 5. SNMP Properties – Traps Tab**

**NOTE** Adding the IP address of the Director Server should be done by the system administrator.
CHAPTER 5
INITIAL CONFIGURATION

This chapter provides procedures for configuring the system so you can:

- Monitor and manage Powerware UPSs from your Director Management Console using LanSafe or the ConnectUPS X-Slot Card user interface
- See a System Information icon on the Director Management Console whenever a system or device is in an alarm or trap situation

Follow the procedures in this chapter on the Director Management Console after the installation of Powerware Extensions (see Figure 6).

To access the Director Management Console, on the Start menu point to Programs→Director and click Management Console. When prompted, enter the UPS device name or Director Server IP address, a User ID, and Password. The Director Management Console opens.

The tasks, which are described in the following sections, are as follows:

1. Compiling MIB Files – see page 9.
2. Discovering SNMP Devices – see page 10.
3. Performing Inventory Collection on SNMP Devices – see page 10.
Compiling MIB Files

The first step in setting up Powerware Extensions is to compile Powerware’s MIB files, `stdupsvl.mib` and `xups.mib`. They are located on your computer in the directory where Director is installed. Compile the MIBs into IBM Director as follows:

1. In the Tasks pane, right click **SNMP Browser**.
   The **Compile a new MIB** button appears. See Figure 7.

2. Click the **Compile a new MIB** button.
   The Select MIB to Compile dialog box opens. See Figure 8.

3. In the Directories area, select **Program Files** and navigate (by double-clicking) to **Director→classes→doc→powerware→director→mib**.
   The entries `stdupsvl.mib` and `xups.mib` appear in the File Name area.
4. In the File Name area, select `stdupsvl.mib` and click **OK**.
   The Select MIB to Compile dialog box closes and the Compile MIB dialog box opens. A Status Message informs you: **MIB Compile Finished**.

5. Compile another MIB. On the menu bar of the Compile MIB dialog box, select **File**→**Select MIB to Compile**.
   The Select MIB to Compile dialog box opens.

6. In the File Name area, select `xups.mib` and click **OK**.
   The Select MIB to Compile dialog box closes and the Compile MIB dialog box opens. A Status Message informs you: **MIB Compile Finished**.

7. On the Menu Bar of the Compile MIB dialog box, select **File**→**Close**.
   The Compile MIB dialog box closes.

**Discovering SNMP Devices**

Discovered SNMP devices appear in the Group Contents pane. To populate or refresh this pane, select **Tasks**→**Discover Systems**→**SNMP Devices** on the menu bar. Allow sufficient time for the system to search your network.

**Performing Inventory Collection on SNMP Devices**

To add information regarding each UPS to Director's SQL database:

1. In the Groups pane, right-click **SNMP Devices**.
   A context menu opens.

2. Select **Perform Inventory Collection**. See Figure 9.

   ![Figure 9. Permanent Inventory Collection Selection](image)

   The Inventory Service window opens. As inventory collection takes place, changes are reported in the Inventory Status pane.

3. Note the yellow ball progress indicator in the lower left corner of the Inventory Service window. When the ball disappears, inventory collection is complete. See Figure 10.
4. On the Inventory Service File menu, select Close to leave the Inventory Service window.

**Creating a Powerware UPS Device Filter**

To create a new Director group that contains only Powerware UPS devices:

1. Right click in an open area of the Groups pane.
   
   A context menu opens. See Figure 11.

   ![Figure 11. Groups Pane Context Menu](image)

2. Click New Dynamic.
   
   The Dynamic Group Editor: New opens. See Figure 12.

   ![Figure 12. Dynamic Group Editor: New](image)

3. In the Available Criteria pane, select Inventory (PC) → Powerware SNMP Data → UPS Manufacturer → Powerware Corporation.
4. Click **Add**.
   The path appears in the Selected Criteria pane. See Figure 13.

![Dynamic Group Editor: New](image)

**Figure 13. Selected Criteria**

5. On the Menu Bar, select **File** → **Save**.
   The Save As dialog opens.

6. Type **Powerware UPS Devices** and click **OK**.
   The Save As dialog closes.

7. On the Menu Bar, select **File** → **Close Group Editor** to return to the Director Management Console screen.

**Creating a Status Update Event Action Plan**

This procedure provides you with a visual notification when a UPS event or trap occurs. This can be accomplished by creating an event action that displays a System Information Icon next to a device when a UPS event occurs. The steps are as follows:

- Create a UPS Simple Event Filter
- Create an Event Action Plan
- Associate the Events Filter with the UPS Events Plan
- Associate an Action with the Event Action Plans
- Associate the Event Action Plan with Devices

Each step is described in the following sections.

**Creating a UPS Simple Event Filter**

1. Select from the menu bar **Tasks** → **Event Action Plan Builder**.
   The Event Action Plan Builder opens. See Figure 14.
2. In the Event Filters pane, right-click **Simple Event Filter**. The **New** button appears.

3. Click the **New** button.

   The Simple Event Filter Builder: New opens with grayed-out options. See Figure 15.

4. Clear the **Any** check box.

   The grayed-out options become available.

5. Click and highlight **UPS**. See Figure 16.
Figure 16. Simple Event Filter Builder: New with Any Cleared and UPS Selected

6. Select from the menu bar **File ➔ Save As**.
7. Enter a filter name, for example, UPS Events, and click **OK**.

Creating an Event Action Plan

Create the Event Action Plan in the Event Action Plan Builder. See Figure 14.

1. Right click on an open area of the Event Action Plans pane. A context menu opens. See Figure 17.

2. Select **New ➔ Event Action Plan**.

   The Create Event Action Plan dialog box opens.

3. Enter a plan name [for this example enter Update Status on UPS Events] and click **OK**.

   The name of the plan appears in the Event Action Plans pane of the Event Action Plan Builder.
Associating the Events Filter with the UPS Events Plan

Drag the **UPS Events** in the Event Filters pane and drop it on the **Update Status on UPS Events** plan in the Event Action Plans pane. See Figure 18.

![Figure 18. Associating the Event Filter with the Event Plan](image)

**Associating an Action with the Event Action Plan**

1. Double-click **Update the Status of the “event” System** in the Actions pane of the Event Action Plan Builder.

   The Customize Action dialog box opens. See Figure 19.

![Figure 19. Customize Action: Update the Status of the “event” System](image)

2. Select **System Information (Generic Status)** for the Status field.
3. Select **Set status** for the Action field.
4. Select from the menu bar **File** → **Save As**.

   The Save Event Action dialog box opens.
5. Enter a name, for example Set Information Status, and click **OK**.
   Set Information Status appears in the Actions pane under **Update the Status of the “event” System**.

**Associating the Event Action Plan with Devices**

1. Click and drag the **Set Information Status** action from the Actions pane to the **Update Status on UPS Events** plan in the Event Action Plans pane. See Figure 20.


3. In the Director Management Console window, expand **Event Action Plans** in the Tasks pane.

4. Drag **Update Status on UPS Events** from the Tasks pane and drop it on the All Systems and Devices group. See Figure 21.

5. You are prompted: Are you sure you want to add this event action plan to the selected group?

6. Click **Yes**.
Figure 21. Completed Console
CHAPTER 6
OPERATIONS

This chapter is a guide to starting the software, and using Powerware Extensions with Director to perform typical monitoring and management tasks. Configuring your system as described in “Initial Configuration” on page 8 is a pre-requisite. Tasks you can perform with Powerware Extensions include:

**Monitoring Tasks**
- Checking UPS Battery Conditions – see page 20.
- Viewing the Load Percent for a UPS – see page 23.
- Setting MIB Attribute Values – see page 26.
- Viewing UPS Inventory Data for Quick System Information – see page 28.
- Viewing UPS Event Logs – see page 30.

**Management Tasks**
- Testing your UPS battery – see page 31.
- Shutting down and restarting a UPS device – see page 32.
- Setting Read-Write Rights in Windows – see page 33.
- Shutting down and restarting load segments – see page 34.
- Configuring event notifications – see page 35.
- Limiting event notifications – see page 35.
- Responding to event notification at the Director Management Console – see page 36.

**Starting the UPS Software**
To perform tasks in LanSafe such as prioritized and sequential shutdowns, orderly shutdowns, local and remote shutdowns and reboots, network-wide UPS testing, and redirecting traps to network management systems, start LanSafe. To perform ConnectUPS X-Slot Card tasks, start the ConnectUPS X-Slot Card interface.

See page 36 and the program documentation.

**Monitoring Tasks**
The SNMP Browser on the Director Management Console is a facility for obtaining information from the UPS and presenting it to the user. The UPS must be capable of supporting the information requested at the Director Management Console. If the UPS does not support the information, the information is not available.

Information details are described in the management information base (MIB) files. LanSafe and the ConnectUPS X-Slot Card systems support the standard MIB (RFC-1628) and a variation of the standard MIB known as stdmib1. In addition, ConnectUPS X-Slot Card systems support the xups MIB.
Start all tasks from the Director Management Console (see Figure 22).

![Director Management Console](image)

**Figure 22. Director Management Console**

**Checking UPS Battery Conditions**

This task uses the SNMP Browser and the Powerware MIB (`stdups1.mib`) for checking UPS Battery Conditions. You can adopt the procedure to access other MIB information available through the SNMP Browser.

1. Do one of the following:
   - In the Director Management Console Tasks pane, drag the SNMP Browser icon and drop it in the Groups pane on a UPS device name or IP address.
   - Right-click a UPS device name or IP address in the Groups pane, opening a context-sensitive menu; click **SNMP Browser**.

   The SNMP browser for the UPS device opens. See Figure 23.
2. In the Device Information pane, expand the tree: `mgmt -> mib-2 -> upsMIB -> upsObjects -> upsBattery`. See Figure 24.

![Figure 23. SNMP Browser](image)

![Figure 24. Expanded Tree](image)
3. See battery information by clicking any of the following attributes:
   - `upsBatteryStatus`
   - `upsSecondsOnBattery`
   - `upsEstimatedMinutesRemaining`
   - `upsEstimatedChargeRemaining`
   - `upsBatteryVoltage`
   - `upsBatteryTemperature`
   Information is displayed as shown in Figure 25.

![Figure 25. Value and Details for upsBatteryVoltage Attribute](image)

4. In addition, ConnectUPS X-Slot Card systems have the following option:
   Expand `private → enterprises → powerware → xups → xupsBattery` to view these attributes:
   - `xupsBatTimeRemaining`
   - `xupsBatVoltage`
   - `xupsBatCapacity`
   - `xupsBattery/AbmStatus`
Viewing the Load Percent for a UPS

This task demonstrates how you can start at the Director Management Console (see Figure 22), create an SNMP Browser, and follow the mgmt tree or the private tree to access Percent Load information. Percent load is the percentage of the UPS power capacity presently being used by the load.

1. Do one of the following:
   - In the Tasks pane, drag the SNMP Browser icon and drop it in the Groups pane on a UPS device name or IP address.
   - Right-click a UPS device name or IP address in the Groups pane, opening a context-sensitive menu; click **SNMP Browser**.

   The SNMP browser for the device opens.

2. Do one of the following:
   - Expand `mgmt→mib-2→upsMIB→upsObjects→upsOutput→upsOutputTable→upsOutputEntry→upsOutputPercentLoad` and see percent load information by selecting the `upsOutputPercentLoad.1` attribute. See Figure 26.

Figure 26. `upsOutputPercentLoad.1` Attribute
• Systems with the ConnectUPS X-Slot Card interface can expand private→enterprises→powerware→xups→xupsOutput and see percent load information by selecting the xupsOutputLoad attribute. See Figure 27.

![Figure 27. xupsOutputLoad Attribute](image)

**Locating Model and Version Information**

This task demonstrates how you can start at the Director Management Console (see Figure 22), create an SNMP Browser, and follow the mgmt tree or the private tree to access model and version information.

**NOTE** If you ever need to contact Powerware Technical Support for assistance, please have your UPS model and software version information available.

1. Do one of the following:
   • In the Tasks pane, drag the SNMP Browser icon and drop it in the Groups pane on a UPS device name or IP address.
   • Right-click a UPS device name or IP address in the Groups pane, opening a context-sensitive menu; click **SNMP Browser**.

The SNMP browser for the device opens.

2. Expand *mgmt→mib-2→System* (see Figure 28).
3. See system information by clicking any of the following attributes:
   - sysDescr
   - sysObjectID – see Figure 28
   - sysUpTime
   - sysServices
   In addition, you can set the following attributes:
   - sysContact
   - sysName
   - sysLocation
   See the following section, “Setting Attribute Values.”

4. Expand `mgmt\mib-2\upsMIB\upsObjects\upsIdent`
   See system information in the following attributes:
   - upsIdentManufacturer
   - upsIdentModel
   - upsIdentUPSSoftwareVersion
   - upsIdentAgentSoftwareVersion

5. Connect UPS X-Slot Card interface systems only: Expand `private\enterprises\powerware\xups\upsIdent`
   See system information in the following attributes:
   - xupsIdentManufacturer
   - xupsIdentModel
   - xupsIdentSoftwareVersion

---

**Figure 28. sysObjectID attribute**
Setting Attribute Values
In the expanded tree for a MIB, the Set icon indicates a value that can be assigned by the system administrator. See Figure 29.

1. In the Value area, type a value in the editable field.
2. Click Set.

   The value that is set appears anyplace in Director where information for this MIB can be accessed.

Using Resource Monitors for Quick System Monitoring
Accessing information one attribute at a time, as described in the above tasks, can be time-consuming. The following Director Management Console task uses the Resource Monitor function to check the battery status of any UPS device in your network. Use this procedure to save time when you regularly check any MIB attribute or set of attributes.

1. Do one of the following:
   • In the Tasks pane, drag the Resource Monitor icon and drop it in the Groups pane on a UPS device name or IP address.
   • Right-click a UPS device name or IP address in the Groups pane, opening a context-sensitive menu; click Resource Monitor.

   The Resource Monitor window for the device opens.

2. In the Available Resources pane, expand the tree as follows: mgmt→mib-2→upsMIB→upsObjects→upsBattery.

   The upsBattery attributes supported by the UPS appear in a list. See Figure 30.
3. Drag one or more attribute icons from the Available Resources pane and drop it in the Selected Resources column in the Selected Resources pane. See Figure 31.

4. Select **File → Save as** and save your selection with a unique name. The name appears as an icon on the Director Management Console Tasks pane under Resource Monitor. See Figure 32.
You can then drag this icon and drop it on the icon for any UPS device in the Group Contents pane, or on the Powerware UPS Devices icon in the Groups pane to obtain this information for the device or devices.

Viewing UPS Inventory Data for Quick System Information

**NOTE** This procedure assumes you have performed an inventory collection on the SNMP UPS devices in your system. See “Performing Inventory Collection on SNMP Devices on page 10.

Director displays information gathered from system inventories, giving you a quick overview of all the UPS devices in your system. To view UPS inventory information, do one of the following:

- **Run the View Inventory Task** – Selecting View Inventory from the Tasks menu produces a list of inventory components applicable to your network. The inventory Query Browser for All Systems and Devices opens. See Figure 33.
Figure 33. Inventory Query Browser, All Systems and Devices

- Drag the Inventory icon from the Tasks pane and drop it on Powerware UPSs in the Groups pane – This produces an inventory list for Powerware UPSs in your network. See Figure 34.

Figure 34. Inventory Query Browser, Powerware UPS Devices

- Drag the Inventory icon in the Tasks pane and drop it on the icon for a device in the Group Contents pane – This opens a list of inventory details applying to the device. See Figure 35.
Viewing UPS Event Logs

**NOTE** This procedure assumes you have configured your system in accordance with the procedures in “Initial Configuration” on page 5.

View the UPS Event Log for your system or devices within the system to study a history of power events to look for trends. You can open a UPS Event Log for all systems or for one system.

1. Do one of the following:
   - **View an Event Log for All Devices** – On the Director Management Console Tasks pane, expand the listing for Event Log and double-click **UPS Events**.
   - **View an Event Log for One Device** – Drag the Event Log icon from the Tasks pane and drop it on the icon for a UPS device in the Group Contents pane.
The Event Log (UPS Events) is shown in Figure 36.

![Figure 36. Event Log for a UPS](image)

### Management Tasks

#### Testing Your UPS Battery

**NOTE** Please observe the following:

- Before testing your battery, set your ConnectUPS X-Slot Card with a community name for read/write access. See your ConnectUPS X-Slot Card manual for the procedure.

- For systems supporting LanSafe (but not the ConnectUPS X-Slot Card), access LanSafe using the Powerware UPS Launcher task and test your battery within LanSafe.

Testing your UPS battery involves placing the system on battery power for several seconds for evaluation. UPSs either pass or fail the test. The following procedure is for ConnectUPS X-Slot Card systems:

1. At the Director Management Console, select the UPS device to be tested and start an SNMP Browser.

2. Expand the browser as follows: `private→enterprises→powerware→xups→xupsTest` and set `xupsStartBattery` to start the test.

3. Review the results in `xupsTestBattery Status`. 
Shutting Down and Restarting a UPS device

**NOTE** Before configuring your software for shutdowns and restarts, note the following:

- **LanSafe Systems** – In your Windows operating system, configure the SNMP Service with a community name with read-write rights. See “Setting Read-Write Rights in Windows” on page 33.

- **ConnectUPS X-Slot Card Systems** – Set your ConnectUPS X-Slot Card with a community name for read/write access. See your ConnectUPS X-Slot Card manual for the procedure.

At the Director Management Console, shutting down and restarting a UPS device is done in the **SNMP Browser** with the following steps:

1. Set the same **Community Name** for the UPS device in the software that you set in LanSafe or the ConnectUPS X-Slot Card. The Community Name must be for read/write access. Do not use the ‘public’ Community Name which is read-only.

2. Set the **upsShowndown** attributes for the shutdown and restart you want.

Access an SNMP browser from the Director Management Console. Select the SNMP Browser task icon, drag it, and drop it onto the icon of a UPS device in the Group Contents pane. The SNMP Browser opens.

Set a Community Name for the device in the SNMP Browser. Right-click the UPS device icon in the Device Information pane. Click the Change Community Name button when it appears. Enter a new name in the Change Community Name dialog box.

Set the upsShutdown attributes in the SNMP Browser. Expand the tree for the UPS device as follows: `mgmt->mib-2->upsMIB->upsObjects->upsControl` and set the desired attributes:

- **upsShutdownType** – Determines the nature of the action to be taken when the countdown of the `upsShutdownAfterDelay` and `upsRebootWithDuration` objects reaches zero. Set at `output(1)` to limit the shutdown to the UPS output receptacles. Set at `system(2)` to cause the entire UPS system to turn off.

- **upsShutdownAfterDelay** – Shuts down (turns off) the UPS output receptacles or the entire UPS system (depending on the value of `upsShutdownType` at the shutdown) after the indicated number of seconds, or sooner if the UPS batteries are depleted. Set to 0 for an immediate shutdown. Set to -1 to abort the countdown. If the system is in the desired state when the countdown reaches 0, nothing happens. That is, there is no additional action if `upsShutdownType` = `system` and the system is already off. Similarly, there is no additional action at that time if `upsShutdownType` = `output` and the output is already off. When read, `upsShutdownAfterDelay` will return the number of seconds remaining until shutdown, or -1 if no shutdown countdown is in effect. On some systems, if the agent is restarted while a shutdown countdown is in effect, the countdown may be aborted. Sets to this object override any `upsShutdownAfterDelay` countdown in progress. When read, `upsShutdownAfterDelay` may return the number of seconds remaining until shutdown, or -1 if no shutdown countdown is in effect. On some systems, if the agent is restarted while a shutdown countdown is in effect, the countdown may be aborted. Sets to this object override any `upsShutdownAfterDelay` already in effect.

- **upsStartupAfterDelay** – Starts the output after the indicated number of seconds. This includes starting the UPS, if necessary. Set to 0 for an immediate startup. Set to -1 to abort the countdown. If the output is already on when the countdown reaches 0, then nothing happens. Settings override the effect of any `upsStartupAfterDelay` countdown or `upsRebootWithDuration` countdown in progress. When read, `upsStartupAfterDelay` returns the number of seconds until startup, or -1 if no startup countdown is in effect. If the countdown expires during a utility failure, the startup does not occur until the utility power is restored. On some systems, if the agent is restarted during a startup countdown, the countdown is aborted.
- **upsRebootWithDuration** – Shuts down (turns off) either the UPS output receptacles or the entire UPS system (as determined by the value of upsShutdownType at the time of shutdown) for the indicated number of seconds. After this period, the output restarts. If the time to perform the request exceeds the requested duration, the requested shutdown and startup cycle are performed in minimum time, but in no case shall this require more than the requested duration plus 60 seconds. When read, upsRebootWithDuration shall return the number of seconds remaining in the countdown, or -1 if no countdown is in progress. If the startup should occur during a utility failure, the startup shall not occur until the utility power is restored.

- **upsAutoRestart** – When set to **on**, causes the UPS system to restart after a shutdown if the shutdown occurs during a power loss caused either by a upsShutdownAfterDelay or an internal battery depleted condition. When set to **off**, prevents the UPS system from restarting after a shutdown until an operator manually or remotely restarts it. If the UPS is in a startup or reboot countdown, the UPS does not restart until that delay is satisfied.

### Setting Read-Write Rights in Windows

Your Microsoft SNMP Agent must be configured for read-write rights. In operating systems other than Windows NT, this is done in the Properties dialog box for the service. See Figure 37.

![SNMP Service Properties Dialog Box (Windows 2000)](image)

**Figure 37. SNMP Service Properties Dialog Box (Windows 2000)**

Configuring the community name and rights should be done by the system administrator.
Shutting Down and Restarting Load Segments

ConnectUPS X-Slot Card systems can shut down and restart individual UPS load segments. Note that the terms Receptacle, Outlet, and Load Group are used interchangeably and all mean “one of a set of controllable, power-switched outputs.”

1. Expand `private→enterprises→powerware→xups→xupsRecep→xupsRecepTable` to view these attributes:
   - `xupsRecep` – The number of independently controllable Receptacles, as described in the `xupsRecepTable`.
   - `xupsRecepTable`

2. Expand `xupsRecepTable` and set the available attributes as necessary. The attributes are as follows:
   - `xupsRecepIndex` – The number of the receptacle or load segment.
   - `xupsRecepStatus` – Enter a value of 1=On/Close, 2=Off/Open, 3=On w/Pending Off, 4=Off w/Pending ON, 5=Unknown.
   - `xupsRecepRecepOffDelaySecs` – The delay in seconds until the load segment or receptacle is turned off. Set to any value other than -1 (0 is immediately). Setting it to -1 causes an attempt to abort a pending shutdown. When this object is set while the UPS is on battery, it is not necessary to set `xupsRecepOnDelaySecs`, since the outlet turns back on when power is available.
   - `xupsRecepOnDelaySecs` – The delay in seconds until the load segment or receptacle is turned on. Set to any value other than -1 (0 is immediately). Setting it to -1 causes an attempt to abort a pending restart.
   - `xupsRecepAutoOffDelay` – The delay after going on battery until the receptacle is automatically turned off. A value of -1 means that this output should never be turned off automatically, but must be turned off only by command. Values from 0 to 30 are valid, but probably inappropriate. The AutoOffDelay can be used to prioritize loads in the event of a prolonged power outage; less critical loads will turn off earlier to extend battery time for the more critical loads. If the utility power is restored before the AutoOff delay counts down to 0 on an outlet, that outlet will not turn off.
   - `xupsRecepAutoOnDelay` – Seconds delay after the outlet is signaled to turn on before the outlet is automatically turned on. A value of -1 means that this output should never be turned on automatically, but only when specifically commanded to do so. A value of 0 means that the receptacle should come on immediately at power-up or for an ON command.

Use `xupsRecepAutoOnDelay` for the following reasons:

1. To coordinate the automatic startup of various outlets, when the normal auto-sequencing of 1 second per outlet is not adequate. For example, they may be used to power up hard disk arrays before CPU units are started.
2. To force additional Down Time during `xupsRecepOffDelaySecs` commands, for equipment to be reset, when the standard Down Time is not long enough.
3. For the -1 value, to ensure that loads won’t be powered until commanded, following power-up or a `xupsRecepOffDelaySecs` command.
**Configuring Event Notifications**

Use the Event Action Plan Builder task for such purposes as sending an Internet (SNMP) e-mail, sending an SNMP trap to an IP host or NetView host, sending a numeric page, or starting a program on a system or on the server.

**Limiting Event Notifications**

Use event filters to tailor the flow of event notifications, ensuring that unwanted messages are not sent.

2. In the Event Filters pane, right-click **Simple Event Filters** and click **New**. The Simple Event Filter Builder:New opens.
3. Clear the **Any** check box and expand the lists for **UPS → Powerware** and **UPS → RFC1628**.

The list of UPS events appears as shown in Figure 38.

4. Select the events of which you want to be notified.

   For a consecutive list of events, press **Shift + the first event** and **Shift + the last event**.
   For a random list of events, press **Ctrl + any event**.
5. Click **File → Save As** to name and save your list.
   The list is created. An icon for the event filter appears.
6. Create an Event Action Plan (see page 14).
7. Associate the Events Filter with the Event Action Plan (see page 15).
8. Associate an Action with the Event Action Plan (see page 15).
9. Associate the Event Action Plan with Your UPS devices (see page 16).

**Responding to Event Notification at the Director Management Console**

At the Director Management Console, view the All Systems and Devices group. If the System Information icon appears beside the icon for a UPS device name or IP address, it indicates an event or trap. See Figure 39.

![System Information Icon](image)

**Figure 39. Device with System Information Icon**

Right-click the System Information icon. A context menu opens. See Figure 40.

![System Information Icon Context Menu](image)

**Figure 40. System Information Icon Context Menu**

Use the context menu for the following functions:

- **Run LanSafe or view a Web card** – Select **Powerware UPS Launcher**. The LanSafe PowerScope or ConnectUPS X-Slot Card Adapter screen opens, depending on the system.
- **See an event log** – Select **Event Log**. A Director Event Log opens.
- **Clear the System Information icon** – Select **System Status → System Information**.

**Starting the UPS Software**

The available UPS software for a device depends on the UPS device communication configuration. For Powerware UPSs with serial communication with a computer, the following procedure starts LanSafe. For Powerware UPSs with ConnectUPS X-Slot Cards communicating with the network, the procedure opens the ConnectUPS X-Slot Card interface.
Do one of the following:

- Drag the **Powerware UPS Launcher** task icon from the Tasks pane and drop it on the **device name** or **IP Address** (in the Groups pane) of a system running LanSafe software or the ConnectUPS X-Slot Card.
- Right-click the **device** icon to open a context menu, then click **Powerware UPS Launcher**.

Systems running LanSafe open with the PowerScope as shown in Figure 41.

![Figure 41. LanSafe v.5 PowerScope](image)

Some of the main LanSafe features and benefits are described in the following table.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Benefit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prioritized and Sequential Shutdown*</td>
<td>Ensures that all network transactions are completed prior to shutdown. Workstations are shut down first, internetworking equipment is shut down next, and servers are shut down last.</td>
</tr>
<tr>
<td>True Orderly Shutdown: Work-in-progress is saved throughout the network</td>
<td>All unsaved information in applications is saved throughout the network. (All applications are orderly closed. The operating systems are gracefully shut down. The UPSs are turned off. The UPSs wait for the power to return before starting up (user defined).)</td>
</tr>
<tr>
<td>Local and remote reboot/shutdown</td>
<td>The UPS can be commanded to reboot a specific computer system either locally or remotely over the network (an orderly shutdown is performed during this event).</td>
</tr>
<tr>
<td>Network-wide testing</td>
<td>Network-wide testing</td>
</tr>
<tr>
<td>SNMP Trap sending</td>
<td>Ability to send SNMP trans to network management systems (NMSs).</td>
</tr>
</tbody>
</table>

*Powerware patented software technology

Systems with the ConnectUPS X-Slot Card open with the ConnectUPS X-Slot Card interface as shown in Figure 42.
ConnectUPS X-Slot Card benefits include the following:

- Provides Web access for easy monitoring and management, any time, any place, with any standard Web browser
- Works with a wide range of third-party network management software programs (SNMP)
- Remote monitoring and control of UPS-protected devices network-wide
- E-mail notification provides real-time UPS event information
- Provides automatic shutdown with NetWatch software
CHAPTER 7

POWERWARE TECHNICAL SUPPORT

If you have any questions or problems with the software, technical assistance is available through the Powerware Web site (www.powerware.com).

Please have your UPS model and software version information available (see “Locating Model and Version Information” on page 24).